Short's Travel Portal - Degraded performance

Incident Report for Short's Travel Management

Resolved

This incident has been resolved.
Posted Jul 19, 2024 - 17:14 CDT

Monitoring

Our systems(Short's Travel Portal, and Airline, Car and Hotel Inventory) are being impacted by a third-party vendor outage beyond our control.

-Avoid travel unless essential.
-Be patient when trying to contact us or any travel supplier.
-Avoid all non-urgent contacts to allow the teams to focus on the most critical support items
Posted Jul 19, 2024 - 09:12 CDT
This incident affected: Short's Travel Portal.