Portal - Self-registration Issues

Incident Report for Short's Travel Management

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 11:14 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 10, 2026 - 10:41 CDT

Investigating

We're investigating an issue affecting self-registration in the Short's Portal. For urgent travel, please contact your account manager to have an account manually built for you.
Posted Jul 10, 2026 - 10:21 CDT
This incident affected: Short's Travel Portal.