Virtual Invoice - Service Degradation

Incident Report for Short's Travel Management

Resolved

Virtual Invoices are now functioning properly.
Posted Apr 11, 2024 - 13:22 CDT

Investigating

We are currently experiencing degraded performance with Virtual Invoices. We're investigating the root cause.
Posted Apr 11, 2024 - 08:55 CDT
This incident affected: Virtual Invoices / Itineraries.