Virtual Invoice - Service Degradation

Incident Report for Short's Travel Management

Resolved

Virtual Invoices have caught up and are now functioning properly.
Posted Oct 18, 2024 - 14:16 CDT

Monitoring

We are currently experiencing degraded performance with Virtual Invoices. Virtual Invoices are backed up, but are releasing slowly.
Posted Oct 18, 2024 - 12:49 CDT
This incident affected: Virtual Invoices / Itineraries.