Virtual Invoice - Service Degradation

Incident Report for Short's Travel Management

Resolved

Virtual invoices are now processing and releasing properly.
Posted Mar 04, 2024 - 11:53 CST

Investigating

We are currently experiencing latency in the processing of virtual invoices causing them to be sent out at a slower than normal rate.
Posted Mar 04, 2024 - 09:58 CST
This incident affected: Virtual Invoices / Itineraries.